Opgradering fra SuSE 9.3 til OpenSuSE 10.2

Jeg har længe gået rundt om den varme grød. Hvornår skulle jeg opgradere min mail/web/wiki/mailman osv osv workstation og server. Den har trofast kørt SuSE 9.3 i lang tid, og med meget få problemer. Alt i alt var SuSE 9.3 et hit, men da der ikke er så lang tid til end-of-life for SuSE 9.3, så tog jeg tyren ved hornene i julen og opgraderede til OpenSuSE 10.2.

Vel bevæbnet med to forskellige backups af al data og en OpenSuSE 10.2 DVD hentet fra klid.dk gik jeg i gang. Det var imponerende at OpenSuSE gik igennem alle pakker og fik godt styr på hvad der skulle opgraderes - pakke for pakke, også selvom jeg ikke har opgraderet løbende via 10.0 og 10.1.

Efter to timer var alle pakker afinstalleret og nye re-installeret, men der var flere ting som var en "om'er" (citat fra Tuborg reklamen) og flere ting som var meget "godkendt".

Jeg hænger på en TDC ADSL forbindelse som kræver (suk) at 192.168.1.2 og 192.168.1.3 begge er oppe til email hhv. web. I SuSE 9.3 var det nemt, men efter opgraderingen virkede netværket ikke. Det drillede en del da YaST ikke bare ville dublere min netadresse. Efter hver reboot var eth0-interfacet ikke oppe :-(

Efter at have manuelt slettet net-interfaceret, have læst mere om FORCE_PERSISTENT_NAMES, fik jeg netværket genetableret. Her ville en re-installation fremfor opgradering været bedre.

Postfix (min e-postserver) med Mailman (e-postlister) klarede opgraderingen perfekt. Alt virkede direkte efter opgradering. Ingen ændringer var nødvendigt. Samme med Apache webserveren med de forskellige moduler jeg har haft installeret. Samba opgradering gik også fint. Denne del var klart "Godkendt" og den var den største del af maskinens funktion.

X kom heller ikke op efter opgraderingen. Det var heldigvis nemt at fikse med at køre "sax2". Efter det blev i orden smed jeg hurtigt gdm ud til fordel for kdm, da gdm systematisk ikke ville starte op. Det var en "Om'er", da almindelige brugere ikke skal udsættes for dette.

Grafikken i OpenSuSE 10.2 er et kapitel for sig, da man nu har "compiz" med. Compiz er det første projekt til Linux og FreeBSD som laver levende 3D grafik på desktoppen. Det er lir, og det er flot, som det kan ses af den følgende video.

Der var flere nyheder i OpenSuSE 10.2 jeg har bidt mærke i.
Det kræver nu ca. 500 MB hukommelse til grafisk installation af programmer. Her savner jeg "apt-get install" som er guld i Debian/Ubuntu, som kan installere med fuld styring af afhængigheder til andre biblioteker og programmer. 500 MB for lidt grafik ovenpå - DYBT GODNAT - Om'er!!!

En anden nyhed "Beagle" lød god. Man kan få indekseret emails, IRC-diskussioner, biller og meget andet for derefter nemt at kunne søge i det. Det måtte prøves, men efter at min 2.8 GHz maskine havde tæsket der ud ad i 24 timer, så måtte slagterkniven på bordet. Ud med "Beagle". Den må jeg prøve med mindre end mine 13.000 biller og tonsvis af emails. Om'er

Alt i alt var opgraderingen ikke så nem som jeg havde håbet, men jeg er næsten 100% tilfreds med OpenSuSE 10.2 på min server/workstation. Programmet til at opgradere/installere programmer er hul i hovedet mht. ressource-forbrug, men resten af OpenSuSE 10.2 fungerer meget super godt.

Jeg er dog stadig meget i tvivl om jeg hellere skulle have lavet en re-installation fremfor en opgradering. Flere af mine problemer lå netop i ting som var ændret meget fra SuSE 9.3 til 10.2.

Kommentarer (8)
sortSortér kommentarer
  • Ældste først
  • Nyeste først
  • Bedste først
Christian Nobel

"Jeg hænger på en TDC ADSL forbindelse som kræver (suk) at 192.168.1.2 og 192.168.1.3 begge er oppe til email hhv. web."

Man kunne vel sætte en billig ethernet router op, som kunne håndtere 2 ip adresser på ydersiden, der så NAT'tede hhv. port 25 og 80 til samme adressse på indersiden?

/Christian

Martin Schlander

Pakkehåndteringen i openSUSE kunne der skrives tykke bøger om.

Men det er altså sådan at du som standard har ikke mindre end to forskellige kommandolinie-interfaces til pakkehåndtering - zypper og rug - og de kræver også et stort hukommelsesforbrug, så det er altså ikke gui'en der koster - det er primært den måde cachen håndteres på - der indlæses nemlig komplette pakkebeskrivelser så de oplysninger f.eks. kan bruges til søgning - men det er dyrt. Dertil kommer ZMD (Zenworks management Daemon) som giver mulighed for at fjernadministrere med en Novell Zenworks server. ZMD er buggy og et svin med ressourcerne - men den er også valgfri.

Se f.eks. denne tegning der viser den rodebutik openSUSE-brugere skal teste og udvikle til enterprise-produkterne:
http://en.opensuse.org/Image:Package-management-in-code10.png

Mange vælger imidlertid at bruge en mere uofficiel løsning - Smart package manager - som har såvel kommandolinie interface som gui.

Se i øvrigt dette appendix i min guide til openSUSE:
http://suse.linuxin.dk/#alternativ

Peter Toft

Jeg har ligesom Christian normalt "nuked" ~/.gnome* ~/.gtk* ~/gconf* (for gnome) or ~/.kde* ved opgradering. Hverken KDE eller GNOME er solide nok til at blive opgraderet IMHO. Derefter har jeg taget enkelte dele af KDE hhv. GNOME opsætningen ind fra backup eller manuelt sat det op igen.

Log ind eller Opret konto for at kommentere