VMware advarer om fejl i backup af virtuelle maskiner

24. november 2015 kl. 15:166
VMware advarer om fejl i backup af virtuelle maskiner
Illustration: Jesper Kildebogaard.
En fejl i måden, hvorpå VMware håndterer ændringer i data undervejs i en backup, kan føre til, at man ender med backups af virtuelle maskiner med fejl i data.
Artiklen er ældre end 30 dage
Manglende links i teksten kan sandsynligvis findes i bunden af artiklen.

VMware advarer om en fejl i ESXi som betyder, at man kan ende med fejlbehæftede data, hvis forsøger at gendanne en virtuel maskine fra en backup. Det skriver The Register.

Fejlen ligger i VMwares Changed Block Tracking-funktion, som anvendes til at lave en backup udelukkende ud fra ændringer i data siden sidste backup. Nærmere bestemt holder funktionen ikke korrekt styr på ændringer, der sker under selve backupprocessen, og over tid kan derfor opstå fejl i backupdata.

VMware har endnu ikke frigivet en opdatering, som løser problemet, men det er muligt at omgå fejlen ved at slå funktionen fra.

Det kan man eksempelvis gøre i Veeam og Trilead, som beskrevet i dette blogindlæg, mens Commvault anbefaler at installere et hotfix og slå funktionen fra.

6 kommentarer.  Hop til debatten
Denne artikel er gratis...

...men det er dyrt at lave god journalistik. Derfor beder vi dig overveje at tegne abonnement på Version2.

Digitaliseringen buldrer derudaf, og it-folkene tegner fremtidens Danmark. Derfor er det vigtigere end nogensinde med et kvalificeret bud på, hvordan it bedst kan være med til at udvikle det danske samfund og erhvervsliv.

Og der har aldrig været mere akut brug for en kritisk vagthund, der råber op, når der tages forkerte it-beslutninger.

Den rolle har Version2 indtaget siden 2006 - og det bliver vi ved med.

Debatten
Log ind eller opret en bruger for at deltage i debatten.
settingsDebatindstillinger
6
25. november 2015 kl. 15:07

Ja jeg har også kørt 5.5 længe derhjemme uden problemer, det er mere problemet med at finde tiden til noget der ikke rigtigt skaber nogen værdi, ud over at "være med".

5
25. november 2015 kl. 13:00

Det er helt fair, men det er alligevel 2+ år siden 5.5 blev frigivet. Du kan roligt opgradere til 5.5.

4
25. november 2015 kl. 10:46

Samme som så meget andet: Tidspres og prioritering. Og så hopper vi sjældent på allernyeste release af noget som helst, det er nemmere at lade andre finde alle børnesygdomme :)

3
24. november 2015 kl. 21:18

5.1? Hvad er grunden til du ikke er kommet op på 5.5U3 endnu?

2
24. november 2015 kl. 17:15

Er 6.0 ikke i beta endnu? Pludselig er jeg ikke så ked af at sidde fast på 5.1 lidt endnu... :P