Nyt udseende, nyt indhold: Her er den nye Firefox

28. september 2017 kl. 10:3014
Nyt udseende, nyt indhold: Her er den nye Firefox
Illustration: Mozilla Firefox.
Betaversionen af den populære browser er ude. Udseendet er totalrenoveret.
Artiklen er ældre end 30 dage
Manglende links i teksten kan sandsynligvis findes i bunden af artiklen.

Tirsdag offentliggjorde Mozilla en betaversion af den længe ventede version 57 af Firefox - og det er noget af det største, der er sket med browseren, siden den blev udviklet.

Vi har tidligere set dele af versionen i skitseform og i deres Nightly- og udviklerversioner, men det er første gang, vi får kigget på hele pakken med ny motor og ny brugergrænseflade.

Den endelige version slippes den 14. november. Hvis du vil teste betaen, kan den downloades her.

Ny brugergrænseflade

Udseendet er blevet totalrenoveret med en løsning kaldet Photon. Udseendet er stilrent og minimalistisk med rektangler i stedet for afrundede hjørner.

Artiklen fortsætter efter annoncen

Hvor designet før mest lignede Chrome, ligner det nu en lækrere variant af Edge. Men hvad man synes om dette, er selvsagt subjektivt.

Skifter motor fra 1997

Mindre subjektivt er det, der gemmer sig bag panseret. I tidligere versioner har Firefox benyttet sig af en ældgammel Gecko-motor, som oprindelig blev produceret til Netscape i 1997.

Det seneste år har ingeniørerne i Mozilla erstattet den gamle motor del for del, og den er nu byttet ud med en splinterny Quantum-motor.

Den nye motor er skrevet i Rust og C++, med Rust som hovedsprog, og kommer med en række nye egenskaber.

Hardwaren kan bl.a. dele processeringen op på flere processorkerner. Mozilla-ansatte har fikset flere hundrede små bugs, som efter sigende giver en række ydelsesforbedringer. Hukommelsen skal bl.a. være reduceret med omkring 30 pct.

Den nye version skulle være dobbelt så hurtig som Firefox 52 og en smule hurtigere end konkurrenten Chrome - i hvert fald hvis man skal tro videoen nedenfor.

Add-on-problemer?

Ifølge Mozillas blog vil gamle browser-add-ons holde op med at fungere med den nye browser.

I dag findes der 19.000 sådanne add-ons, men kun en fjerdedel af disse understøtter den nye version.

Forhåbentlig får udviklerne lyst til at opdatere, før den endelig version lægges ud, og browserens 500 millioner brugere skifter version.
Denne artikel stammer fra norske digi.no

14 kommentarer.  Hop til debatten
Denne artikel er gratis...

...men det er dyrt at lave god journalistik. Derfor beder vi dig overveje at tegne abonnement på Version2.

Digitaliseringen buldrer derudaf, og it-folkene tegner fremtidens Danmark. Derfor er det vigtigere end nogensinde med et kvalificeret bud på, hvordan it bedst kan være med til at udvikle det danske samfund og erhvervsliv.

Og der har aldrig været mere akut brug for en kritisk vagthund, der råber op, når der tages forkerte it-beslutninger.

Den rolle har Version2 indtaget siden 2006 - og det bliver vi ved med.

Debatten
Log ind eller opret en bruger for at deltage i debatten.
settingsDebatindstillinger
14
17. oktober 2017 kl. 13:58

"Vorherre bevares," som en vis bowler-klædt lille mand plejede at sige, jeg ved godt at det er "nyt, smart, og moderne" med firkanter og store, ensfarvede flader -- men er det en god brugergrænseflade? Jeg er rigelig træt af, at man i Android ikke kan se hvor knapper og popup-dialoger egentlig slutter, men hey - lad os da få mere af det!

/get off my lawn

13
2. oktober 2017 kl. 09:32

Har Chrome de 30+ udvidelser ?

Næh, understøttelsen af Chrome og Firefox 57+ er nogenlunde lige sløj. Det værste er at Firefox 57 indtil videre ikke understøtter hverken LastPass eller Xmarks. :-( Det kommer forhåbenlig inden udgivelsen af Firefox 57.

Men det kan jo være, at det blive mere indlysende, når den endelige udgave kommer og vi opdager alle de forchromede hastighedsforbedringer.

Jeg har lige prøvet betaen og det sparker altså røv. Jeg er ked af at miste nogle plugins (f.eks. Tab Mix Plus og CoLT) men hastighedsforbedringen er det hele værd i mine øjne.

Og det er jo ikke fordi det ikke har været meldt ud i god tid. Så får vi også luget ud i extensions som ikke bliver vedligeholdt...

12
30. september 2017 kl. 16:46

Den gode nyhed er at WebExtension API er (næsten) kompatibel med Chrome:

Extensions built with WebExtension APIs are designed to be compatible with Chrome and Opera extensions: as far as possible, extensions written for those browsers should run on Firefox with minimal changes.</p>
<p>However, Firefox currently has support for only a limited set of the features and APIs supported by Chrome and Opera. We're working on adding more support, but many features are not yet supported, and we may never support some.

11
30. september 2017 kl. 15:26

Seriøse udviklere af extensions vil gøre dette ret hurtigt, så efter kort tid vil problemet kun omfatte extensions, der ikke er i aktiv udvikling.

Hvis det bare handlede om lidt API-ændringer, kunne man jo have lavet en bagud-kompatibel API.. men der er tale om en ny og indskrænket standard.

Nu er det bare noget jeg konstaterer... Evidensen er overvældende i Mozillas kommentarspor, på Reddit osv.: Man mister både seriøse udviklere og seriøse brugere. Læs f.eks. dette blog-indlæg fra en udvikler, der bare har fået nok: http://fasezero.com/lastnotice.html

Hvis alle kunne indse nødvendigheden af at flytte til WebExtensions nu her, så ville der ikke være så meget larm. Desværre. Men det kan jo være, at det blive mere indlysende, når den endelige udgave kommer og vi opdager alle de forchromede hastighedsforbedringer.

10
29. september 2017 kl. 17:52

Har Chrome de 30+ udvidelser ?

9
29. september 2017 kl. 17:27

Nu er det jo også sådan at nogle APIer mangler, så man ikke kan lave webextensions alternativer.

Jeg er bestemt ked af at 80% af mine 30+ extensions snart holder op med at virke og tænker at det måske er tid til at skifte til Chrome..

8
29. september 2017 kl. 09:55

Vel er det irriterende, men hvis den gamle platform for extensions har vist sig usikker eller på andre måder uhensigtsmæssig, så foretrækker jeg trods alt, at platformen opdateres, selv om det medfører, at extensions skal skrives om. Seriøse udviklere af extensions vil gøre dette ret hurtigt, så efter kort tid vil problemet kun omfatte extensions, der ikke er i aktiv udvikling.

Det er ikke væsentligt anderledes end drivers til Linux: Når der kommer nye kerner, ophører mange gamle drivers at fungere, fordi systemkald og invarianter ændres. Det betyder, at du på meget gamle maskiner bliver nødt til at bruge en gammel kerne, da drivers til f.eks. grafikkort (som ikke længere forhandles) ikke er opdateret til den nye. Ja, det kan være irriterende, men løsningen er den samme: Brug en ældre version af Firefox (eller Linux), hvis du ikke kan undvære en extension (eller en driver).

7
28. september 2017 kl. 23:41

Husk profilbackup mindst en gang hver uge, uanset om man installerer en ny Ff eller ej. Compact/Zip subdir .mozilla

6
28. september 2017 kl. 19:31

Jeg tror ikke, at kritikken i tidligere kommentar var, at artiklen på digi.no er dårlig. Det var en ærgrelse over, at den ikke er gengivet med billeder!

Det er virkelig god stil, at V2 linker til, hvor kilden er fra.

Et tilsvarende godt eksempel er Global Nyt, der ofte copy-paster artikler på engelsk, skriver en dansk overskrift og kun oversætter de sværeste ord.

5
28. september 2017 kl. 18:18

Jeg synes at nogle af digi.no artiklerne er rigtig gode og jeg synes det er OK at man reproducerer dem her. Tak for det. Nogle gange er digi.no tidlig ude med (nogle gange) gode og gennemarbejdede artikler. Det er værd at skele til dem.

3
28. september 2017 kl. 14:58

Jeg har læst følgende... og jeg ved ikke, om det er sandt... men better safe than sorry.

There is however the problem of downgrades breaking with 55 so people relying on non webextension addons will be forced to scrap their profile directories which is a shame.

2
28. september 2017 kl. 14:56

Ifølge Mozillas blog vil gamle browser-add-ons holde op med at fungere med den nye browser.

Firefox's værdi måles: Firefox + extensions. Summen er rent teoretisk, men det er 100% sikkert, at en (ej bagudkompatibel) brugergrænsefladeopdatering er mindre værd end de mange extensions. I en anden målestok, kunne man overveje arbejdsindsatsen i Photon vs. Extensions. Det ville være fint, hvis de glade disruption-typer også lige gad skrive opdateringer til alle de extensions, som de breaker...

Læser man de mange kommentarer på Mozillas blog, kan man også se, at frustration ikke er til at tage fejl af... kun en enkelt Mozilla-ansat synes at sidde foran tasterne for at forsvare den nye udgave.

Meget trist udvikling. Man kan håbe, at den mere nære udgivelse af FF accelererer transitionen. Det skal også siges i Mozillas forsvar, at de har lavet et projekt, der foreslår alternativer til gamle extensions, som ikke portes.

1
28. september 2017 kl. 14:43

Kan vi ikke hæve niveauet bare en lille smule? Fair nok at man henter artikler fra andre medier, men kunne man ikke bare gøre en minimal indsats?

I en sådan artikel ville det være klædeligt med et par billeder til at illustrere forskellen. Ligeledes var det forvirrende at læse "i hvert fald hvis man skal tro videoen nedenfor."

Kigger man så på den oversatte kilde-artikel, så er begge dele faktisk til stede, og det giver lidt mening igen.

Hvis ambitionen ikke er højere, så ville jeg faktisk foretrække at I droppede den slags fyld artikler. Ellers få lidt mere hjerte med i det.