NemID sender Mac-styresystem fra 2009 ud i kulden

Bruger du Mac OS X 10.5 Leopard, som var standard frem til august 2009, er NemID ikke længere understøttet. Fremover vil kun version 10.6 og 10.7 være understøttet, og Mac-computere med PowerPC-processor kan dermed ikke bruges til NemID.

Opdatering: Nets DanID fortæller, at Mac-brugere med OS X 10.5 stadig kan bruge NemID, men på eget ansvar. Der er ikke længere understøttelse eller support fra DanID's side. Men alle PowerPC-baserede Macs kan ikke længere bruge NemID. Læs mere på NemID's hjemmeside.

Læs også: DanID: Du kan sagtens bruge NemID på MacOS X 10.5

Vil du bruge NemID, skal du som Mac-bruger holde dig til de nyeste udgaver af styresystemet Mac OS X.

En opdatering af NemID har nemlig sendt alle, der bruger Mac OS X 10.5 Leopard, ud i kulden. Det fortæller Per Møller Olsen, der med sit firma Olsen Multimedia lever af support til Mac-brugere.

»Det er fuldstændig absurd. Det er godt for min pengepung, for nu skal jeg ud og hjælpe mange med at opgradere til en nyere version af Mac OS X, men ellers synes jeg, at det er horribelt dårligt,« lyder det fra Per Møller Olsen.

Mac OS X 10.5 udkom i 2007 og blev i august 2009 afløst af version 10.6 Snowleopard. Siden har Apple også udsendt en version 10.7 Lion, der kom i 2011. Dermed kan version 10.5, som nu bliver droppet af DanID, sammenlignes tidsmæssigt med Windows Vista.

Men ligesom mange Windows-brugere stadig holder fast i Vista eller den endnu ældre Windows XP, har man som almindelig Mac-bruger ikke nødvendigvis opgraderet en 10.5-version, hvis man er tilfreds med computeren, som den kører nu, forklarer Mac-supporteren.

»En Mac-bruger opgraderer ikke styresystem i tide og utide, og nogle bruger deres computer i mange år. Der er stadig masser derude med PowerPC-Macs, som nu ikke kan bruge NemID,« siger han.

Da Apple valgte at skifte arkitektur fra PowerPC-processorer til Intels X86-platform i løbet af 2006, blev version 10.5 af styresystemet nemlig det sidste, som understøtter den gamle type Macs. Her er der altså ikke andet at gøre end at købe en ny computer, hvis man vil bruge NemID fremover.

»Det hænger ikke sammen med, at man gerne vil have alle med, også Udkantsdanmark. Jeg har en del lidt ældre Mac-brugere, som nu skal betale mig for at hjælpe med at opgradere eller købe en ny computer for at kunne bruge netbank eller modtage e-mails fra det offentlige,« siger Per Møller Olsen.

Han er heller ikke tilfreds med, at ændringen sker, uden at DanID har meldt klart ud. Det fremgår nu bare af NemID-hjemmesiden, at NemID kræver Mac OS X 10.6 eller nyere.

Mac-brugere i NemID-modvind

At være Mac-bruger i NemID-land har i forvejen været besværligt, pointerer han.

»Mac-brugere har været i modvind med NemID, fordi bankerne har valgt ikke at supportere Mac. Så skal man tale med NemID-supporten, men det er som at slå i en dyne, for de anbefaler bare, at man opgraderer til den seneste version af Mac OS X,« siger Per Møller Olsen.

Har man faktisk den nyeste Lion-version af styresystemet, er der også bøvl. Her har Apple nemlig for nyligt valgt at slå Java fra som standard i browseren, af sikkerhedshensyn, så nu skal Mac-brugere, som aldrig før har haft noget med Java at gøre, gå imod styresystemets sikkerhedsadvarsler for at bruge NemID.

»Det virker underligt for brugerne. Og fordi Java ellers er fulgt med som standard, har Mac-brugere jo ikke været vant til at gå op i, om man har Java eller ej, eller hvilken version det er,« siger han.

Tips og korrekturforslag til denne historie sendes til tip@version2.dk
Følg forløbet
Kommentarer (31)
sortSortér kommentarer
  • Ældste først
  • Nyeste først
  • Bedste først
Jesper Frimann

Nu er det her kun et lille hjørne af NemID's support problemer.

Når det f.eks. kommer til browsere.
Firefox 8,9,10,11 og 12 er ikke supporterede, det er version 7.
Chromium 15,16,17,18,19,20, 21 er ikke supporterede, den eneste supporterede er version 14 på Windows, når det bruges privat.

Safari er så kun supporteret på MacOS og du skal så op på 5.1.
Man kan så gå videre med Java versioner og implementeringer.

Så hvor stor en del af NemID's bruger, hvis vi kun ser på hvad folk bruger af browsere er egentlig supporterede ?

Først hvad er understøttet:
https://www.nemid.nu/support/tekniske_krav/understoettede_programmer/int...

Hvem bruger hvad ?
http://gs.statcounter.com/#browser_version-ww-monthly-201204-201204-bar

Så hvis man summer lidt sammen, så er kun 31% af browswer trafikken supporteret.

Og så er vi ikke begyndt at sortere fra pga. Java versioner og releases, og OS'er.

Tja ja.

// Jesper

Thomas Hansen

og kulde og kulde... banker og eBoks køre fint på mobil...

men god trolling der.

Danske Bank appen hjælper ikke meget med at logge ind på arbitrære NemID brugende sites. Der er ikke ligefrem en app for hver selvbetjeningsløsning på kommunernes hjemmeside (og det håber jeg da ikke der skal spildes digitaliseringskroner på at fremstille).

Tim Andreasen

Jakob Damkjær: prøv lige at tage en puster og læs hvad manden skriver istedet for at kalde andre for trolle.
Er det muligt at han ærligt mener at det er ærgeligt at NemID heller ikke virker til andre (og nyere) Apple produkter - hvilket måske ikke er en så unaturlig tanke når nu artiklen netop handler om Apple produkter?
Hvor kommer Android og Windows ind i det henne? Rooolig, artiklen og kommentaren er en kritik af NemID, ikke Apple - så bare slap af igen.

Og OT:
Det er på høje tid at NemID begyndte at understøtte de platforme som er i brug, heriblandt tablets (Særligt iPad da der nok er flest af dem!). Det lader til at de gør det modsatte, og indskrænker dem..

For konens vedkommende har iPad´en i dag har overtaget hele hendes daglige behov - med undtagelse af NemID - og hun er nok ikke den eneste der har det sådan.

Jesper Lund

Når det f.eks. kommer til browsere.
Firefox 8,9,10,11 og 12 er ikke supporterede, det er version 7.

Har du en officiel udmelding (dokumentation) om dette? Det kunne være ret interessant.

Et af kravene for at kunne få lov til at bruge NemID er jo at man holder sin software opdateret, og jeg formoder at det krav også omfatter browsere. Medmindre DanID vil fastholde at Firefox 7.0.1 (eller whatever) er den seneste version af Firefox 7, er det svært at se hvordan man kan forene "vi supporterer kun FF 7" med deres egne krav..

EDIT: havde overset link til DanID hvor det står, men siger supporten det samme? Det kunne jo også være en webside der ikke er opdateret.

Jesper Frimann

@Jesper Lund

havde overset link til DanID hvor det står, men siger supporten det samme? Det kunne jo også være en webside der ikke er opdateret.

Selve support matrix'en er mindst opdateret 1 Oktober 2011
(https://www.nemid.nu/support/tekniske_krav/understoettede_programmer/inf...)

Jeg tvivler stærkt på, at man f.eks. er sprunget 5 version i firefox på et halvt år.
Om alt er, så er det her den officielle side for, hvad der er supported, så det er jo hvad folk må forholde sig til.

Når man kun bruger sit NemID til netbank login, får man ikke direkte adgang til NemID supporten. Jeg har måtte gå igennem min bank, som så har været igennem BankData som så har snakket med NemID supporten, sidste gang jeg havde problemer.
Der gik der næsten 2 måneder før at NemID kom med svaret:

Dette problem er kendt fra andre kunder, og der findes desværre ikke andre løsninger pt. end at prøve fra en anden maskine ( i dette tilfælde jo så en tredje).

Her havde jeg afprøvet både en Supporteret platform, XP med IE 8 og en hel del "usupporterede", andre kombinationer af Java/Browser og OS. Og jeg henviste også til deres support matrix i min korrespondance med dem.
Fælles for alle dem der ikke virkede var dog at de kørte med Full disk encryption, som f.eks. pgp.
Lige så snart jeg lavede en linux virtuel maskine uden encryption og wupti så virkede det.

Igen det der får mig op i det røde felt er det, at man på den ene side har en politik om at folk skal være patchede og køre på en sikker platform, men at så er platformen ikke supporteret.
Det ligner en god gammel konstrueret fralægning af ansvar.

// Jesper

Jakob Peterhänsel

Et er at Nets-DanID har så forbandet svært ved at supporterer moderne teknologi, og konstant holder DK tilbage med en 5-10 år.

Noget helt andet er, at HELE Danmarks online ID-styring er ejet af et firma, som er ejet af UDENLANDSK kontrol!

Og så forlyder det desuden, at Nets er ved at flytte serverparken udenlandsk, så Hele Danmarks Id-system, ikke længere er i DK..

Jeg er i Chok over hvad vores politikere for sat i drift efterhånden!

Jan Lunddal Larsen
Jimmy Frydkær Dürr

Fælles for alle dem der ikke virkede var dog at de kørte med Full disk encryption, som f.eks. pgp.
Lige så snart jeg lavede en linux virtuel maskine uden encryption og wupti så virkede det.

Er der ikke lidt Stasi over dette. Kan de ikke snage i dit system virker deres amatør-agtige snage-ware ikke. Men giv dem "adgang" og de sidder i deres skumle rede og gnækker som tandløse gamle tanter.

Christian Hedemann Olsen

Det er sikkert vanskeligt at finde en god alternativ løsning, men hvis man laver browserbaserede løsninger, er det bare "the dark side of the force" at satse på plugins.

Det kan godt være man kan nogle smarte tricks med java-applets, men som det har været beskrevet i andre version2-artikler, er java-plugin'et en motorvej ind bag sikkerheden på brugerens computer, og som vi har set tidligere (læs:Flash) er det for usikkert at give en enkelt producent ansvaret for at udvikle og vedligeholde på tværs af alle OS- og processor-typer.

Jeg håber der snart kommer en ren og sikker løsning som kører 100% i browseren. Der kommer et 'Like' fra mig til DanID, når den er klar!

Rasmus Arndal

Man kunne jo bare vælge at skifte operativsystem, hvis man ønsker sin PowerPC basserede Applecomputer på nemid (og alt muligt andet nyt og smart).

Mange GNU/linux distro'er findes jo i PowerPC udgaver.
Selv den nyeste Ubuntu 12.04 kan jo installeres på en gammel g3 eller g4 powerbook.

Så håbet er ikke helt ude for de gamle mac produkter derude.

Einar Petersen

Jeg synes da det er synd for Mac brugerene at de bliver skubbet ud i kulden sammen med Linux brugerene og at NemID med død og pine vil tvinge os til at installere proprietært software på vores computere fori at de ikke kan finde ud af at lave en simpel cross platform løsning, men reelt sovser vores computere ind i slam kode som nu åbenbart også er en officiel stats trojaner...

Nej du, Mac brugerene har min sympati onkring denne problematik og ja desværre ser det ud til at man skal til at have en maskine (vm/fysisk) til sine ID krævende ting og så en anden til normalt brug som det er nævnt i denne tråd - Synes bare det er noget svineri at det er staten der forsøger at tvinge mig tilbage til de horrible dage med Windows og nul kontrol over ens eget system....

Nej NemID er en ommer - så er det sagt....

Jimmy Christiansen

Her er der en klar fejl i artiklen:

Da Apple valgte at skifte arkitektur fra PowerPC-processorer til Intels X86-platform i løbet af 2006, blev version 10.5 af styresystemet nemlig det sidste, som understøtter den gamle type Macs. Her er der altså ikke andet at gøre end at købe en ny computer, hvis man vil bruge NemID fremover.

Der er adskillige linux distributioner der virker på PPC-Mac's.

Så det er muligt at opgradere OS på en PPC-Mac, bare ikke med Apples eget styresystem.

Edit: Øv, der var en der overhalede mig indenom mens jeg skrev og researchede :o)

Jimmy Christiansen

Ja det er et godt spørgsmål. Jeg har prøvet at se om der var eksempler at finde på det.
Men med et opdateret styresystem og java som er grundkravene. Så skal NemID x§!"#¤%&/ understøtte det.

Men det er jo et af problemerne med NemID: den er ikke ordentligt platform uafhængig.
Så der vil være en hulens masse arbejde med at holde OS- og arkitektur-specifikke versioner opdaterede og nogenlunde sikre.

Peter Eriksen

Ja, men Java koden er blot en lille bootloader som downloader binære filer skrevet til udvalgte systemarkitekturer. Denne kode er skjult i GIF filer.

Jeg vidste godt det var sådan, men alligvel så rejser samtlige hår på ryggen sig hver gang jeg læser det.
(Efterfulgt af et dybt suk mens hovedet banker mod bordet)

Jeg har tit overvejet, at flytte og skifte statsborgerskab men jeg troede virkeligt ikke, at det ville være DK's fælles login løsning der gav mig det sidste skub ud over landegrænsen.

Jan Peter Bagge

Der er ikke noget så ødelægende for en god debat, som at forholde sig til faktuelle forhold. Ja, jeg har selv oplevet at jeg ikke kunne logge ind på NemID med Firefox 3.6.25, MEN, jeg kan skam stadigvæk logge in med Safari-browseren version 5.0.6. . . og det på en fin gammel PowerBook G4-15".
( Jeg har lige prøvet det her i aften og det virker :-) .)

Jeg ved ikke hvorfor det er sådan , det kan godt være at det er FireFox der er problemet, men altså, hvis man ønsker at bruge en PPC-G4, så kan man stadigvæk klare sig med med OS-10.5.8 og Safari 5.0.6.
(Og ja, hvis man ikke ved om det er en PPC eller en x86 Mac, så skiftede alle de bærbare navn fra "Powerbook" til "MacBook" da man gik over til Intel x86)

Jeg skal lige huske at bemærke at 10.5 kun kan installeres på 'nyere' PPC (G4, >867MHz ) så hvis man har en PPC-G3 så kan man ikke komme højere end OS-10.4

Så altså . . . hvis man vil fortsætte med OS-X (Unix) på sin PPC-Mac, så kan man holde sig i luften v.h.a. Safari.

.. og efter at have opdateret FireFox til 3.6.28, så virker NemID også med FireFox :-)) .

Log ind eller Opret konto for at kommentere