Firefox dropper plugins inden udgangen af næste år

12. oktober 2015 kl. 14:059
Mozilla vil fremover ikke understøtte plugins i webbrowseren Firefox – bortset fra Adobe Flash, der får lov at leve videre.
Artiklen er ældre end 30 dage
Manglende links i teksten kan sandsynligvis findes i bunden af artiklen.

Inden udgangen af 2016 vil der ikke længere være understøttelse for hovedparten af de såkaldte NPAPI-plugins i webbrowseren Firefox, det skriver Mozilla i et blogindlæg på deres webside.

»Plugins er en kilde til problemer med ydelsen, nedbrud og sikkerhedsproblemer for brugerne,« skriver Mozilla om årsagen til deres beslutning.

Med denne beslutning følger Mozilla i hælene på Google og Microsoft, der også har droppet understøttelsen af NPAPI-plugins i henholdsvis Chrome og Edge. Samtidig vil den nye 64-bit version af Firefox til Windows blive lanceret helt uden understøttelse for NPAPI-plugins, da den ifølge Mozilla ikke behøver supportere et eksisterende økosystem af brugere og plugins.

Mozilla understøtter fortsat Adobe Flash

»Vi bliver ved med at understøtte Adobe Flash som en undtagelse fra vores generelle politik omkring plugins i Firefox, da Flash fortsat er en almindelig del af weboplevelsen for mange brugere. Mozilla og Adobe vil fortsætte med at samarbejde om at forbedre oplevelsen af Flash i Firefox med hensyn til såvel stabilitet som ydelse, funktioner og sikkerhed,« skriver Mozilla på deres blog.

Artiklen fortsætter efter annoncen

Mozilla arbejder desuden sammen med Unity for at sikre at Unity-baseret indhold fremover vil kunne afvikles i browseren uden plugins. Ligesom et samarbejde med Oracle skal sikre, at de websider der bruger Java, også fremover vil kunne fungere i Firefox.

9 kommentarer.  Hop til debatten
Denne artikel er gratis...

...men det er dyrt at lave god journalistik. Derfor beder vi dig overveje at tegne abonnement på Version2.

Digitaliseringen buldrer derudaf, og it-folkene tegner fremtidens Danmark. Derfor er det vigtigere end nogensinde med et kvalificeret bud på, hvordan it bedst kan være med til at udvikle det danske samfund og erhvervsliv.

Og der har aldrig været mere akut brug for en kritisk vagthund, der råber op, når der tages forkerte it-beslutninger.

Den rolle har Version2 indtaget siden 2006 - og det bliver vi ved med.

Debatten
Log ind eller opret en bruger for at deltage i debatten.
settingsDebatindstillinger
9
13. oktober 2015 kl. 08:05

Lasse, Fire IE extension/plugin, fungerer fint til at vise IE websider i firefox.

8
12. oktober 2015 kl. 19:31

Slå lige koldt vand i blodet, venner. Jeg håber vi forsat kan nyde godt af den store vifte af extensions selv om der bliver lukket ned for plugins. Ingen steder kan jeg læse, at det store community for dødsstødet (for det ville det virkelig være).

7
12. oktober 2015 kl. 18:08

Slettet.

6
12. oktober 2015 kl. 16:48

Det er så dejligt når man har nogle arbejds relaterede portaler man er afhængig af som kun kan køre i IE.

Hah!

De hjemmesider, som jeg bruger bære præg af, at programmøren havde forkærlighed for en bestemt browser. Det betyder, at jeg skal skifte browser, alt efter hvilken hjemmeside jeg skal ind på.

Så jeg har brug for både Internet Explorer og Firefox, men også Chrome.

Hvor ville det være nemt, hvis man var ikke afhængig af Java / Flash plugin og alt var kodet i HTML5. Desværre tror jeg at det kommer til at tage år før det sker.

I den sammenhæng er det lidt katoffel / katoffel om jeg skal bruge noget der ligger på det interne net, eller bruge en ekstern hjemmeside. Problemet gælder for begge.

I takt med at plugins bliver deaktiveret i både Chrome og Firefox, så er det ikke blevet nemmere, da hjemmesiderne er ikke blevet opdateret med en løsning.

5
12. oktober 2015 kl. 16:08

Så er jeg mere rolig, så er der flere FF-ekstra features som jeg kan bibeholde.

Dog i tvivl om min IE emulator er et plugin eller extension da den er listet begge steder i FF.

Det er så dejligt når man har nogle arbejds relaterede portaler man er afhængig af som kun kan køre i IE.

4
12. oktober 2015 kl. 16:04

Præcis, det er kun NPAPI plugins de lukker af for, ligesom Chrome har gjort.

3
12. oktober 2015 kl. 15:01

Firebug er vel ikke et binært npapi-plugin, men en addon som kører i Firefox. Den bliver så vidt jeg kan gennemskue ikke påvirket.

2
12. oktober 2015 kl. 14:49

På lang sigt bliver det det vel fint, men hold da op der er da et par værktøjer jeg kommer til at mangle. bla. firebug og IE-mode.

Og så er der da lige nogen som skal tage sig sammen til at udvikle nogle nye interfaces til deres sites og enheder.... især Skat & Virks java logins for firmaer.

Der er utrolig mange netværksenheder der har behov for diverse plugins, eks Synology, Axis, Hikvision, faktisk næsten hver og eneste netværks kamera enhed, hænger helt eller delvis sammen med java eller anden form for afspiller plugin til afkodning af videoer.

1
12. oktober 2015 kl. 14:44

Så vi stoppe med Plugin på grund af sikkerhed. Med lader den allerstørste synder på den front forsætte ?

Hvis de lod alle andre forsætte, men stoppet Flash, så ville det give en bedre sikkerhed.

Men efterhånden er de gode plugin den eneste grund til jeg bruger FF så fred være med den. Skal den i graven med adblock ?