Digitaliseringsstyrelsen om manglende Chrome-Java: Vi kan ikke styre Google

På Linux vil Firefox blive supporteret i stedet for Chrome, der ikke længere understøtter Java og dermed NemID. Også Chrome til Windows står til at miste Java-understøttelse.

I kølvandet på Version2’s historie om, at Chrome til Linux ikke længere understøtter Java og dermed NemID, har Digitaliseringsstyrelsen været i kontakt med Nets, der står bag den digitale selvbetjeningsplatform.

Og kontorchef i styrelsen Cecile Christensen oplyser nu på den baggrund, at browser-alternativet Firefox fungerer med Java og NemID i stedet for Chrome under Linux. ligesom Nets oplyser, at Firefox vil blive supporteret af virksomheden i stedet for Chrome på Linux-platformen Ubuntu.

Læs også: Google trækker stikket på NemID-platform i Chrome til Linux

»Vi kan jo ikke styre, hvad Google, Oracle eller tilsvarende virksomheder gør. Det er ærgerligt, men det er noget, vi har svært ved at gøre noget ved,« siger kontorchef i Digitaliseringsstyrelsen Cecile Christensen og tilføjer:

»Heldigvis er vi jo på vej med en JavaScript-baseret løsning, som vi forventer at kunne gå i luften med inden længe.«

Cecile Christensen fortæller, at der i kontrakten mellem Digitaliseringsstyrelsen og Nets om NemID er krav om, at understøtte gængse kombinationer og browsere og andre applikationer og operativsystemer.

Af listen over supporterede browsere på Digitaliseringsstyrelsens hjemmeside NemID.nu fremstår Chrome dog stadig som den eneste browser, der er supporteret til den udbredte Linux-distribution Ubuntu.

Hvis en browser er supporteret, så er den automatisk også understøttet fremgår det af siden. Supporteret vil i denne sammenhæng sige, at brugeren har mulighed for at få hjælp af NemID-supporten.

Nets, der står bag NemID, har efter Version2 har rettet henvendelse til dem, undersøgt sagen. Ulrik Marschall oplyser i en mail til Version2, at Firefox nu vil blive supporteret i stedet for Chrome til Linux:

»Under 0,1 % af de daglige NemID-logins stammer fra brugere med kombinationen Chrome og Linux, så vi anbefaler, at de Linux-brugere der bliver ramt af denne problematik, benytter en anden browser, f.eks. Firefox, når de bruger NemID. Det er blandt andet den stigende tendens til at vælge Java fra på flere platforme, der igangsatte NemID JavaScript-projektet, som forventes afsluttet ultimo juni 2014. Herefter kan alle NemID-løsninger med nøglekort køre på JavaScript-løsningen,« skriver han og fortsætter:

»NemID.nu vil blive tilrettet, så Chrome ikke længere fremstår som supporteret i forbindelse med Linux platformen.«

Allerede i september 2013 gjorde Google opmærksom på i et blogindlæg, at understøttelsen af plugin-strukturen NPAPI, som Java anvender, forventes at blive udfaset fra browseren i løbet af 2014 - og også hvad Windows-versionen af Chrome angår.

Læs også: Digitaliseringsstyrelsen udskyder NemID til mobilen i 11. time

Version2 har i den forbindelse spurgt Digitaliseringsstyrelsen, om det kommer bag på styrelsen, at Chrome er på væk fra Java-understøttelse.

»Dengang, vi udviklede NemID, var Java meget bredt understøttet, som på det tidspunkt var den mest langtidssikrede teknologi, vi kunne vælge. Men vi har jo godt kunnet se i et stykke tid, at der er en bevægelse på vej væk fra Java henover flere udbredte platforme. Og det har også været med til at bevirke, at vi udvikler JavaScript-løsningen i stedet for. Som vi nu forventer er en god og langtidssikret teknologi. Men der vil jo altid være en udvikling på dette område,« siger kontorchef i Digitaliseringsstyrelsen Cecile Christensen.

Google meldte ud i september 2013, at de ville fjerne supporten på Chrome i løbet af 2014, så det burde vel ikke komme bag på jer eller Nets?

»Nej, og det mener jeg heller ikke, det gør. Projektet med JavaScript har jo stået på i et år nu. Så vi har jo vidst, vi skulle over på en anden platform. Det tager bare noget tid at udvikle.«

Siden denne artikel er skrevet, har Digitaliseringsstyrelsen meldt ud, at den planlagte lancering af NemID-JavaScript bliver udskudt. Styrelsen havde ellers tidligere bebudet at, den ville finde sted på udvalgte hjemmesider 28. maj. Det har ikke efterfølgende umiddelbart været muligt at få en kommentar fra Digitaliseringsstyrelsen. Det arbejder vi på.

Tips og korrekturforslag til denne historie sendes til tip@version2.dk
Kommentarer (15)
sortSortér kommentarer
  • Ældste først
  • Nyeste først
  • Bedste først
#1 David Rechnagel Udsen

Jeg bruger Chromium som min »lortebrowser«, altså den hvor jeg besøger sider der skal bruge Flash og Java, så jeg kan holde det ude af min standardbrowser (som i dette tilfælde er Firefox). Det er mig en kende nedern hvis jeg ikke længere kan opretholde denne opdeling.

  • 1
  • 3
#4 Mogens Hansen

Projektet med JavaScript har jo stået på i et år nu. Så vi har jo vidst, vi skulle over på en anden platform. Det tager bare noget tid at udvikle.

Med andre ord: Så må brugerne bare vente på at vi nosser os færdige, og hvis vi ikke kan få det til at virke til tiden, er det bare ærgeligt for dem.

  • 8
  • 2
#7 Lars Tørnes Hansen

Man kan også bruge letvægtsudgaven med en seperat styresystem-bruger og så bruge cgroups (control groups) på Firefox browseren der skal bruge NemID.

Mere om cgroups:

Det næste-sidste link er ret godt, synes jeg.

  • 0
  • 0
#8 Palle Simonsen

God tone og faglighed tak!

Der var en tråd for 1 måneds tid siden om god tone i debatten, som passen kan genbesøges af og til.

Jeg vil tro den pågældende journalist er lydhør overfor saglig kritik fremført i en passende tone. Jornalisterne er ikke nødvendigvis it-uddannet på samme niveau som læserne, så en skævert forekommer af-og-til.

Nye tablets kører Android 4.2 eller 4.4. Så vidt jeg kan huske, har en tablet aldrig kørt android 3.x

  • 6
  • 5
#9 Morten Borg

Chrome på Mac har meget længe manglet Java support, så her er det desværre ikke en nyhed.

Er ofte nødt til at skifte til Firefox for at bruge Java.

Det bliver dejligt med JavaScript baseret NemID, men for mange virksomheder er det ikke nok. Eksempelvis benytter jeg dagligt Post Danmarks Pacsoft system som er Java-baseret - et sted hvor JavaScript pt. ikke kan erstatte det, da der kommunikeres direkte med ens printer.

For mig tror jeg snart konsekvensen bliver at jeg hopper over på Firefox selvom det er modvilligt.

  • 1
  • 0
#15 Anders Holm

Det ændrer ikke på, at jeg fx aldrig har set en Honeycomb tablet. Alle har enten kørt en ældre Android version eller 4.0. Honeycomb var kun ude i et halvt år, før det blev udskiftet med Ice Cream Sandwich, hvilket gjorde der ikke nåede at blive lanceret mange tablets med Honeycomb.

  • 0
  • 1
#16 Anders Holm

Det ændrer ikke på, at jeg fx aldrig har set en Honeycomb tablet. Alle har enten kørt en ældre Android version eller 4.0. Honeycomb var kun ude i et halvt år, før det blev udskiftet med Ice Cream Sandwich, hvilket gjorde der ikke nåede at blive lanceret mange tablets med Honeycomb.

  • 0
  • 1
Log ind eller Opret konto for at kommentere