Cybersikkerhedsmyndighed: Udviklere, skift væk fra Python 2 i tide

Illustration: Selenit, BigStock
Python 2 vil fra nytår ikke længere være understøttet. Alle siger, at det er på tide at opdatere til Python 3, men alligevel kører mange biblioteker på gamle versioner.

Den britiske cybersikkerhedsmyndighed, National Cyber Security Centre, giver nu en advarsel til udviklere, der stadig arbejder med gamle versioner af Python.

Advarslen kommer, ifølge ZDNet, fordi Python 2.x ikke længere vil blive opdateret fra 1. januar 2020.

»Hvis du stadig bruger 2.x, så er det på tide at få portet din kode over i Python 3. Hvis du fortsætter med at bruge moduller, der ikke er understøttede, bringer du din organisation og data i fare, da sårbarheder før eller siden vil opstå, og ingen vil fixe det,« lyder det fra myndigheden.

Myndigheden understreger også, at hvis bliver ved at bruge gamle versioner for biblioteker, som andre har brug for, så bringer du også andre udviklere i risiko.

Vil undgå ny WannaCry

Man kan måske undre sig over, at en myndighed udtaler sig så direkte om et specifikt kodesprog, men Python er i dag et af de mest anvendte kodesprog overhovedet, og en sårbarhed i Python vil potentielt kunne ramme tusindvis af systemer.

»WannaCry er et klassisk eksempel på, hvad der kan ske, hvis du kører på software, der ikke længere er understøttet,« lyder det fra den britiske myndighed.

På trods af opfordringer fra både myndigheder og holdet bag Python, viser National Cyber Security Centres opgørelse, at der fortsat er mange Python-biblioteker, der kører på version 2.x.

Tips og korrekturforslag til denne historie sendes til tip@version2.dk
Kommentarer (0)
sortSortér kommentarer
  • Ældste først
  • Nyeste først
  • Bedste først
Log ind eller Opret konto for at kommentere
IT Company Rank
maximize minimize