Apples 'XP-problem': Ingen sikkerhedsopdateringer til fire år gamle Snow Leopard

Opdateret: En femtedel af verdens Mac OS X-brugere får ikke længere sikkerhedsopdateringer. Apple vil ikke længere understøtte OS X 10.6 Snow Leopard, som blev solgt indtil sommeren 2011.

Om godt en måned vil de mange millioner Windows XP-brugere ikke længere få sikkerhedsopdateringer fra Microsoft, hvilket har fået masser af opmærksomhed, selvom der kom en – godt nok ikke ret populær – afløser for XP tilbage i 2007, altså for syv år siden.

Men hos Apple går det hurtigere med at falde i unåde, for det 4,5 år gamle styresystem OS X 10.6 Snow Leopard får heller ikke længere sikkerhedsopdateringer. Det skriver amerikanske Computerworld.com.

Apple har netop sendt opdateringer ud, der skal lukke et kritisk SSL-sikkerhedshul, men hullet optræder ikke i Snow Leopard. Ved tidligere lejligheder er Snow Leopard dog også blevet sprunget over, mens de nyere styresystemer har fået en sikkerhedsopdatering. Den seneste sikkerhedsopdatering til 10.6 Snow Leopard kom således i september 2013.

Læs også: Apple retter SSL-sikkerhedshul i OS X

Læs blogindlæg: Apple's SSL-brøler

Snow Leopard blev afløst af OS X 10.7 Lion i sommeren 2011, så har man købt en Mac for lige over 2,5 år siden, uden at opgradere styresystemet siden da, er man i Apples øjne for langt bagud til at få kritiske sikkerhedsopdateringer.

Selvom det typisk er noget billigere og mere overskueligt at opgradere til nyere versioner af OS X, sammenlignet med at skifte til en ny version af Windows, bruger 19 procent af klodens Mac-ejere stadig Snow Leopard.

Apple har tidligere haft et princip om at understøtte den nuværende og den forudgående version af OS X, men i takt med at kadencen gik op, og der kom en ny version cirka en gang om året, blev det udvidet med en ekstra generation. I dag kommer Mac-maskiner med OS X 10.9, så version 10.8 og 10.7 er blevet patchet.

Opdatering: Det fremgik oprindeligt af artiklen, at Snow Leopard også var ramt af SSL-hullet - det er ikke tilfældet.

Tips og korrekturforslag til denne historie sendes til tip@version2.dk
Kommentarer (15)
sortSortér kommentarer
  • Ældste først
  • Nyeste først
  • Bedste først
Uffe Seerup

Jeg havde forstået at 10.6 stadig brugte et ældre library og ikke havde "goto fail" problemet.

Der er imidlertid andre sikkerhedshullet som er blevet lappet i den seneste opdatering. Angribere vil kunne reverse engineer'e og finde ud af om de også findes i OS X 10.6

Men hvis OS X 10.6 ikke indeholder SSL "goto fail" bør artikelteksten (og overskriften) rettes.

Kristian Larsen

Udgangspunktet for Apple er vel at 3 år er så gammelt så det pr. definition skal udskiftes :/
Jeg har aldrig forstået update politiken for OS X. Burde være som så meget andet, du får minor updates men ikke major mm. du betaler upgrade prisen.

Men tvivler på at Apple brugere vil protestere i horder mod "Apple som altid gør det rigtige"tm.

Jakob Damkjær

Det er ikke 3 år det er 6 år...

http://www.apple.com/osx/how-to-upgrade/

Alle med 10.6.8 kan hvis deres hardware er indenfor den tidsramme der står i den første parentes er dem der gratis kan opgradere til Mac OS X 10.9.2 Maverics.

iMac (Mid 2007 or newer) (sen 2006 kan opdateres til 10.7.5)

MacBook (Late 2008 Aluminum, or Early 2009 or newer) (sen 2006 kan opdateres til 10.7.5)

MacBook Pro (Mid/Late 2007 or newer) (sen 2006 kan opdateres til 10.7.5)

MacBook Air (Late 2008 or newer) (alle kan opdateres til 10.7.5)

Mac mini (Early 2009 or newer)
(Midt 2007 kan opdateres til 10.7.5)

Mac Pro (Early 2008 or newer)
(Alle kan opdateres til 10.7.5)

Xserve (Early 2009) (sen 2006 (dvs alle Intel) kan opdateres til 10.7.5)

Og er dermed indenfor den opdaterede ramme og dermed sikret.

Så hvad med at skære tyrefæses lidt ned og acceptere at Mac OS X 10.6.8 på ingen måde er at sammenligne med Windows XP og man skal ha hardware fra 2006 før man ikke er dækket af sikkerhedsopdateringer fra Apple.

At der så stadig er nogen der ikke opdatere er mere noget at gøre med at de ikke er opmærksom på sikkerhed.

NB! Kilde på 10.7.5 opdaterings rammen er MacTracker.

Jakob Damkjær

Og det var relevant hvis der ikke var en gratis upgrade sti for rigtig gammel hardware og endnu ældre hardware kan opgraderes til 10.7 (Lion) hvis man skulle sammenligne med XP.

Så der er meget få der ikke kan opdatere og en stor del af dem gratis. Ikke lige tilfældet med XP pcere så at mene det er forfærdelig kundeservice er lidt en overdrivelse der kun kan lade sig gøre hvis man har et tunnelsyn der udelukker den gratis opdaterings sti jeg peger ud.

Jakob Damkjær

Tak =)

Har også læst BOFH http://www.theregister.co.uk/2014/02/21/bofh_2014_episode_2/

Men når du er nået til at kalde folk navne er det nok fordi du er løbet helt tør for argumenter og falder tilbage til den sidste forsvarslinje dvs. jeg har gået i skole så derfor har jeg ret. Men hvis det eneste du har, så vil jeg håbe at du måske havde hørt lidt bedre efter på IT skolen, så du kunne formulere nogen faktiske argumenter.

PS! den BOFH er ikke særlig morsom og dødstrusler pga. at nogen du skal servicere ikke forstår en i de fleste øjnes er en ligegyldig teknikalitet er ikke et tegn på en sund sindstilstand. Det er indikativt for manglende empati og dårlige kommunikative evner...

Erik Jensen

Ved sku ikke hvor du får 3 år fra.

Den sidste Mac der ikke kan opgraderes fra snow leopard, blev solgt i 2007.
Derefter kan de køre 64 bit og opgraderes. Du kan stadig købe Lion for 20$ hvilket folk burde kunne få råd til. Og endelig kan nyere opgraderes til mavericks gratis.

Martin Nielsen

Jeg tænker lidt at problemet ikke er et XP-problem, men at hardwaren har været for god.

Min gamle Macbook fra 2006 kører stadig uden problemer og starter på 40 sekunder, men selve operativ systemet kan ikke opdateres yderligere.

Hvis man ser nærmere på statistikken, vil jeg gætte på at der reelt kun er tre store grupper indenfor Mac kategorien. Det vil være 10.4 (Tiger), 10.6 (Snow Leopard) samt 10.9 (Mavericks). Tiger var det sidste OS der understøttede Power PC, Snow Leopard det sidste der understøttede en tidligere generation Intel og Mavericks understøttes at de nuværende generationer af Intel.

Tiger blev lanceret i 2005, sammen med Intel Macs. De computere der blev solgt fra 2005, kunne blive opdateret til Snow Leopard. De computere solgt før 2005, kunne højst få Tiger og de sidste sikkerhedsopdateringer kom i 2010. Samme historie som denne artikel, bare med en anden generation hardware.

Hvis vi skal sammenligne med XP/Windows 7, så er der tale om et XP-problem, da den hardware der kan kører XP også kan køre Windows 7 (i langt de fleste tilfælde). Det er dog en lidt skrabet version af Windows 7, hvis ens hardware ikke er så kraftig.

Der er altså mere tale om et hardware problem, end et XP-problem.

Allan Jensen

<q>Udgangspunktet for Apple er vel at 3 år er så gammelt så det pr. definition skal udskiftes :/</q>
Nej. Apple's udgangspunkt er 2 år. Det plejede at være ET år. De sidste 2 versioner er ved udgivelsen af en ny version kun den nyligt udgivede og den forrige version, typisk ét år gammel. Nu understøtter de de tre sidste versioner hvilket ved udgivelsen af en ny er 2 år tilbage...

Apple... suk

Per Erik Rønne

Jeg har fire Mac'er.

Den 13" MacBook Pro jeg sidder på nu, og som er den seneste uden Retina-skærm.

En syv år gammel 13" MacBook, den 'nyeste' som højst kan køre Lion, som den kører. Kan betragtes som en back-up option for den jeg faktisk bruger, skulle der ske noget med den.

En ligeledes syv år gammel MacMini, som har kørt OSX Server, som højst kan køre Lion - og som nu kører Oracle Linux med tilhørende relationsdatabase.

Og en 'Mac Pro' fra 2002, som højst kan køre Leopard. Hvilket den p.t. alligevel ikke kan, da strømforsyningen er defekt.

Ser jeg på hvilke maskiner der ikke kan køre det Lion, der stadig bliver opdateret, skal jeg tilbage til 2006. Så Apple understøtter altså maskinerne syv år tilbage. Og måske længere, da det af ovenstående er fremgået at udgaver af OSX før Lion slet ikke led af den netop rettede fejl; sidste opdatering af Snow Leopard er mindre end et halvt år gammelt.

Log ind eller Opret konto for at kommentere